2.2 What's New in V14 SP1?

An outline of the changes in this version of the Deployment Tool.

Patches built with SP1 can only be applied to a Version built with SP1

Previously it has been recommended to create a Version after any major upgrade to ensure the appropriate LANSA runtime changes are shipped.  This is now enforced with SP1.

A patch cannot be applied to a Version built prior to SP1.

Patches do not support Before and After Command processing

Before and After Command processing is no longer supported in patches.

Conversion of Pre-V13 Packages and Templates is no longer supported

Version 13 included an option to convert a pre-V13 package into a base Version of your Application, and also included Upgrade Options in the Installation Settings to support upgrading a pre-V13 installation of your application to V13.

Template conversion was also provided for pre-V13 templates to V13 templates.

These specialized features are no longer supported in Version 14.  If you have a requirement to convert a pre-V13 package or upgrade a pre-V13 installation of your application this must be executed using LANSA Version 13.

It is strongly recommended that rather than attempting to convert or upgrade a pre-V13 Application you start with a new Version of the product as this will ensure you include the new features and settings which are available post Version 14.  These include the automatic deployment of LANSA Web Services Extension, Web images, Web Administrator, Integrator Studio and Java Service Manager and other LANSA Features.