General Requirements

You should have: