2.18 Apache Axis 1.4 WS-Security and WS-Addressing

Refer to 2.17 SOAP Agent Message Handler.

Apache Axis 1.4 offers WS-Security capability by using the Apache WSS4J, XML-Security and WS-Addressing projects.

These projects do not support the latest changes in the implementation of WS-Security and WS-Addressing. Also these projects do not support new Web Services specifications such as WS-Policy, WS-Federation, WS-Trust and WS-SecureConversion.