You are here: Visual LANSA User Guide > 1. Getting Started with Visual LANSA > 1.5 Setting up Your Workspace > Autohide
Autohide

You can obtain more room to work with the objects open in the Editor using autohide.

 

The tabs will immediately adopt the Standard tab style and will behave as follows for the Standard tab style.

   

 

When Autohide is set on, the tab folder is hidden but the tabs still remain visible as shown here:

 

Click on the tab to re-display the contents.

 

To return the tab folder to its original position, display one of the tab folders and click on the Attachbuttonattach  ) button.

 

 

1.5 Setting up Your Workspace

Visual LANSA User Guide
1. Getting Started with Visual LANSA
1.1 How Do I Get Started?
1.2 Before You Begin Checklist
1.3 How Do I Populate the Repository?
1.4 Using LANSA Other Products
1.5 Setting up Your Workspace
1.5.1 Editor Options
Setting the Editor Options
General
Source
Web - General tab
Web - Design tab
Debug
Compile
Version Control
Editor Style
Reset Editor
1.5.2 Using Tabs
Tab Style
Docking and Undocking Tabs
Button Options
Add or Remove Favorites
Can't Find a Tab?
Change Tab Locations
Quickly Resize Tabs
2. Editing Objects
2.1 Dialogs
2.1.1 Create Dialogs
2.2 Fields
2.2.1 Create Fields
2.2.2 Copy Fields
2.2.3 Field Definition Tab
2.2.4 Field Rules and Triggers Tab
Adopt Field Rules and Triggers
2.2.5 Field Visualization Tab
2.3 Forms
2.3.1 Create Forms
2.4 Functions
2.4.1 Create Functions
2.4.2 Copy Functions
2.4.3 Design Functions
2.4.4 Function Screen Designer
Screen Details Tab
Screen Representation
General Tab
Function Keys Tab
User Keys Tab
Fields, Groups and Lists Tab
Field Tab
Add Text
Create a Screen
2.4.5 Function Report Designer
2.5 Processes
2.5.1 Create Processes
2.5.2 Copy a Process
2.5.3 Functions Tab
2.5.4 Definition Tab
2.5.5 Attachments Tab
2.5.6 Special Entries Tab
2.5.7 Process Parameters Tab
2.5.8 Action Bar Table Tab
2.5.9 Menu Structure Tab
2.6 Resources
2.6.1 ActiveX
Register ActiveX Controls
2.6.2 Bitmaps
Create Bitmaps
2.6.3 Cursors
Create Cursors
2.6.4 External Resources
Register Individual External Resources
External Resource Definition Tab
2.6.5 Icons
Create Icons
2.6.6 Multilingual Variables
Create Multilingual Variables
Copy Multilingual Variables
2.6.7 System Variables
Create System Variables
2.6.8 Themes
Create Themes
2.6.9 Visual Styles
Create Visual Styles
2.6.10 Widgets
Create Widgets
2.6.11 .NET Components
Register .NET Components
2.7 Reusable Parts
2.7.1 Create Reusable Parts
2.8 Server Modules
2.8.1 Create Server Modules
New Base Server Module
New Application Server Module
New WEB API Server Module
2.8.2 API Definition Tab
URL Anatomy
Definition
Service Name
Partition Handling
Language Handling
Publish as Swagger V2
Publish as OpenAPI V3
Info
Security requirements
Paths
Name
Summary
Description
Path Parameters
Operations
Parameters
Request
Responses
Schema Object
Components
Schema
Types
Properties
Standard Types
Security Schemes
Drag/Drop
2.9 Tables
2.9.1 Create Tables
2.9.2 Copy Tables
2.9.3 Table Columns Tab
Add Columns to a Table
Add Multiple Columns to a Table
2.9.4 Indexes Tab
2.9.5 Table Rules and Triggers Tab
2.9.6 Access Route Tab
2.9.7 Batch Control Tab
2.9.8 Table Attributes Tab
2.9.9 Data Preview Tab
2.9.10 Relationships Tab
2.9.11 Cross References Tab
2.9.12 Virtual Derivation Tab
2.10 Views
2.10.1 Create Views
2.11 Web Pages
2.11.1 Create Web Pages
2.12 Organizers
2.12.1 Database Diagrams
Create a Diagram
2.12.2 Lists
Create a List
Static List
Dynamic List
Save Results of Search as List
Impact List
Add and Remove searches
Change the Impact List's Definition
Add Object Types
Specify Filters for your Objects
Filter Criteria
Save and Run an Impact List
Review the Results
Export the Impact List
2.13 System Information
2.13.1 Message Files
2.13.2 Partitions
Create Partitions
Partition Definition Tab
Language Settings Tab
Frameworks Tab
Groups Tab
2.13.3 Primitives
2.13.4 Remote Systems
Create Remote System
System Definition Tab
2.13.5 Templates
Create a Template
Copy a Template
Template Help
2.13.6 Users
New User
User Privileges Tab
2.13.7 Tasks
Create a Task
2.14 WAM Development Objects
2.14.1 Web Application Modules (WAMs)
Create a WAM
Copy a WAM
Outline tab – WAMs
Details Tab (Property Sheet)
Webroutine Output
Create a Web Page
Design Versions
Using External Resources with WAMs
Style External Resources with WAMs
Script External Resources with WAMs
2.14.2 Web Components
2.14.3 Weblets
Create Weblet
Copy Weblet
Create Weblet Design
Replace Visualization Weblet
2.14.4 Technology Services
Technology Services Definition Tab
Create Technology Service
3. Standard Editor Tabs
3.1 Editor Features
3.2 Check In Tab
3.2.1 Check In Details Dialog
3.3 Check Out Tab
3.3.1 Check Out Details Dialog
3.3.2 Refresh Master Object List
3.4 Compile Tab
3.4.1 Compile options
3.4.2 Compile Details Dialog
3.5 Controls Tab
3.6 Cross References Tab
3.7 Debug Tabs
3.7.1 Debug - Breakpoints Tab
3.7.2 Debug - Variables Tab
3.7.3 Debug - Call Stack Tab
3.8 Design Tab
3.8.1 Design Commands on the Ribbon
Home Tab Design Commands
Use Templates
Expose as ActiveX
Lock Design
Show Controls
Show Popups
Select All/None/Invert Selection
Bring Forward/Send Backward
Layout Tab
New Layout
Table Layout Row Height
Moving Table Layout Rows
Adding Table Layout Rows
Table Layout Column Width
Moving Table Layout Columns
Adding Table Layout Columns
Deleting the Table Layout
Attaching All Child Components to the Table Layout
Positioning an Object in the Table Layout
Theme Tab
Style Tab
3.8.2 Design Tab for Functions
3.8.3 Other Objects in the Design Tab
3.8.4 Saved Definitions
3.8.5 Copy Component
3.9 Deploy Tab
3.9.1 Deploy Any List
3.10 Details Tab
3.10.1 Component Details Tabs
Component Details - Properties tab
Component Details - Events tab
Component Details - Methods tab
3.11 Favorites Tab
3.12 Features Tab
3.13 Go To Tab
3.14 Outline Tab
3.14.1 Showing Layouts and Styles in the Outline Tab
3.14.2 Outline Tab Context Menu for Components
3.15 Propagation Tab
3.15.1 Connection History Dialog
3.16 Repository Details Tab
3.17 Repository Help Tab
3.17.1 Languages
3.18 Repository Tab
3.18.1 Show Repository Tab
3.18.2 Repository Tab Contents
3.18.3 Information about Objects
3.18.4 View Object Properties
3.18.5 Alphabetical Groupings
3.18.6 Object Cross-References
3.19 Samples Tab
3.20 Source Tab
3.20.1 Rules for the Editor
3.20.2 Find
3.20.3 Replace
3.20.4 Auto Complete
3.20.5 Assistant Tab
List of Commands
Specify Parameters
The Last Saved Command
Specify Attribute Values for Parameters
3.21 Version Control Tab
3.22 Web Design Tab
4. Editor Features
4.1 Open an Object
4.2 Delete Objects
4.3 LANSA Import Facility
4.3.1 Import Tab
4.4 Version Control
4.4.1 Visual LANSA Actions
4.4.2 Version Control Actions
4.4.3 Viewing Version Control Status
4.4.4 Version Control Commands
4.4.5 Version Control – Git Integration
Git Repository
Create a Git Repository
Remote Repositories
Existing Git repositories
Git Actions on Objects
Commit
Resolve Conflict
Show History
Show Version Control Differences
Show Changes
Change Colors
Map of Changes
Show in Folder View
Show Repository
Git Repository Actions
Pull
Push
View Branch
New Local Branch From
Checkout
Merge From
Merge - Abort
Rebase Onto
Rebase - Abort
Rebase - Continue
Rebase - Skip
Viewing Git Status
4.5 Import Excel Worksheets
4.5.1 Installing the Driver
4.6 Export a List to Excel
4.7 Search Facilities
4.7.1 Repository Find
Find Results
4.7.2 Text Search
4.7.3 Source Code Find and Replace
4.8 Interface Indicators
4.9 Printing in Visual LANSA
4.9.1 Print Dialog
4.10 Help Text
4.10.1 LANSA Online Documentation
5. Executing Applications
5.1 Execute Process
5.2 Execute Function
5.3 Execute Form
5.4 Execute Web Page
5.5 Execute WebRoutine
5.6 Execute Options
5.6.1 As Client to Any Server (manual connection)
5.6.2 As Client to RDML IBM i Server
5.6.3 As Client to RDMLX IBM i Server
5.6.4 As Client to Linux Server
5.6.5 As Client to Windows Server
5.6.6 As Windows Application
5.6.7 In Web Browser
5.6.8 XML Java Client
5.6.9 Prompt for additional execution Parameters
5.7 Additional Execution Parameters
5.7.1 Default Printer
5.7.2 Debug
5.7.3 Debug Host
5.7.4 Trace
5.7.5 Max Trace Lines
5.7.6 Trace Level
5.7.7 Trace Categories
5.7.8 Heap Validation
5.7.9 Show command line
5.7.10 Render Type
5.7.11 Graphics Processing
5.8 Fatal Errors
5.8.1 Visual LANSA Error Log Viewer
5.8.2 Web Runtime Error Log Viewer
6. Debugging Applications
6.1 Start Debugging
6.2 Set Breakpoints
6.2.1 Breakpoints
6.2.2 Breakpoint Properties
6.3 Variables
6.3.1 Include/Exclude Fields
6.3.2 Changing Values
6.4 Call Stack
6.5 Run Parts of the Application
6.6 Exclude/Include Applications
6.7 Animate Application Execution
6.8 Debug Web Pages
6.9 Debug WAMs
7. Tracing Applications
7.1 Create a Trace Handler
7.2 Example Trace Handler
7.3 Use the Trace Handler
7.4 Example Use of Tracing
7.5 Trace Output
7.6 Trace Handler Guidelines and Performance
8. Editor Basics
8.1 The Ribbon
8.1.1 Home Tab
8.1.2 Tools Tab
8.1.3 Navigate the Ribbon with Access Keys
8.2 Quick Access Toolbar
8.3 Mini-Toolbars
8.4 Context Menus
8.5 Commands
8.6 Keyboard Shortcuts
8.6.1 Keyboard
8.6.2 Close Tabs
8.6.3 Move the cursor in the Source tab
8.6.4 Position the current line
8.6.5 Tag and comment lines
8.6.6 Collapse and expand code
8.6.7 Format text
8.6.8 Deletions
8.6.9 Copy, cut and paste
8.6.10 Help
8.6.11 Selection
8.6.12 Undo/Redo
8.6.13 Find and replace
8.6.14 Command Assistant Keystrokes
8.6.15 Menu editor
8.6.16 Select with the mouse
8.7 Product Information
8.7.1 About LANSA
8.7.2 Installation Details
8.7.3 Privileges